Issue
- The app shows high values too often
- The ring on the air purifier lights up red or purple
- My air purifier suddenly has the highest fan speed
- The air quality light is red or purple too often
Applies to
- AEG AX9 series air purifiers
- AEG AX5/AX7 series air purifiers
Resolution
Dust accumulated in the air quality sensor(s) can result in incorrect readings and affect the product performance. Use a vacuum cleaner with a soft brush to remove any dust that might accumulate in this area.
Vacuum (at least) once a month if the product is used daily. Never use abrasive, harsh cleaning tools - this can damage the sensor.
If the problem persists, even after multiple cleaning attempts, please contact an AEG / Electrolux service station for further guidance.
AX9 series sensor location
AX5/AX7 series sensor location
Cause
- Dust can enter the sensor and cause the values for particles to be displayed incorrectly in the app and the air quality light to glow red on the air purifier