Blast Chiller - the temperature indicated by the food sensor is incorrect

Last updated 05/05/2020 06:20

Issue:

  • Blast Chiller - the temperature indicated by the food sensor is incorrect

Applies to:

  • Blast Chiller

Resolution:

1. Check that the food sensor is positioned in the product core.

2. Only use timed or assisted programs and call the support service for replacement.

Cause:

  • Food sensor inserted incorrectly
  • The food sensor is damaged
Book a repair
Book a repair

Need to arrange a technician visit? Repairs in warranty are free of charge and we are here to support you after your warranty has expired. Authorised Technicians and genuine parts for complete peace of mind.

Spare parts & Accessories
Spare parts & Accessories

Find original spare parts for your appliance in our webshop and have them delivered directly to your door.