Issue
- The kettle stopped working, unresponsive buttons, leaking water
Applies to
AEG kettles
Resolution
Problem | Possible Cause | Solution |
The appliance switches off before boiling | Too much limescale at the base of the kettle | Run the decalcifying procedure |
The appliance does not switch off | Close the lid until it locks | |
Insert the strained correctly | ||
The appliance cannot be switched on | After operating with little or no water, the appliance has not cooled down sufficiently | Allow to cool a short time and try again |
The appliance cannot be switched on | fuse/socket issue | Check if the kettle is correctly connected to the electrical supply and if the socket is working. (Check by plugging in something you know is working into that socket - hairdryer, etc.) |
IMPORTANT
If the appliance starts leaking please stop using it and contact our customer service at 03445 611 611.
Cause
- Limescale
- Fuse / Socket
- Leaking water