AEG K7-1-6BP-U gourmet kettle troubleshooting

Last updated 06/03/2023 08:15

Issue

  • The kettle stopped working, unresponsive buttons, leaking water

Applies to

  • AEG kettles

Resolution

ProblemPossible CauseSolution
The appliance switches off before boilingToo much limescale at the base of the kettleRun the decalcifying procedure
The appliance does not switch off
Close the lid until it locks
Insert the strained correctly
The appliance cannot be switched onAfter operating with little or no water, the appliance has not cooled down sufficientlyAllow to cool a short time and try again
The appliance cannot be switched on
fuse/socket issueCheck if the kettle is correctly connected to the electrical supply and if the socket is working. (Check by plugging in something you know is working into that socket - hairdryer, etc.)


IMPORTANT 

If the appliance starts leaking please stop using it and contact our customer service at 03445 611 611.

Cause

  • Limescale
  • Fuse / Socket
  • Leaking water
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