Issue:
- Robotic vacuum cleaner displays the wrong time
Applies to:
- Pure i9 series robotic vacuum cleaner
- RX9 series robotic vacuum cleaner
Resolution:
1. Make sure the robotic vacuum is connected to the internet and wait until it receives the correct time.
- If it does not correct time within 24 hrs, reconnect the robotic vacuum cleaner.
- Follow the instruction on the phone app or in the user manual. Download user manual.
Cause:
- The robot has not received updated time from the server.